June 16, 2020 at 8:37pm

macOS 10.15 and Ruby < 2.4

Het is lang geleden dat hier nog eens iets technisch te lezen was maar dit ga ik nog nodig hebben.

Ik had vanavond Ruby 2.1.10 nodig op mijn machine ofte ruby-install ruby 2.1.10.

Het probleem

Dat installeren ging vlotjes maar het werkte voor geen meter. OpenSSL hel.
gem install bundler -v 1.17.0 kwam terug met het volgende:

Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS source

Wat ik nog niet wist: Ruby 2.3 and lower not being compatible with OpenSSL 1.1

De oplossing

brew install rbenv/tap/openssl@1.0
ruby-install ruby 2.1.10 --no-install-deps -- --with-openssl-dir=$(brew --prefix openssl@1.0) --disable-install-doc

Met dank aan ravicious

Veel plezier!


ruby openssl rbenv chruby ruby-install


Previous post
Inside the syndicate Japan’s Yakuza: Inside the syndicate stond blijkbaar al 5 jaar starred in mijn Feedbin account. Waarschijnlijk vond ik dat toen interessant maar had
Next post
Achter een ijsje We zijn vanavond een ijsje gaan eten bij dé Jozef. Dat moet van vorige zomer geleden zijn. Te voet natuurlijk. Het is ons nog maar eens opgevallen